1. 苏葳的备忘录首页
  2. 开发工具

ADT安装时的悲剧

android adt eclipse安装ADT,很认真的翻墙看了文档,官方推荐使用的Eclipse是Classic版本,推荐使用的Android SDK是exe安装包。结果JDK重装成1.6.0.24后,验证正常。但安装这个exe安装包时无论如何都会提示找不到JDK安装路径。只得下载zip包解压缩了事。后来才发现个比较雷人的解决方法,提示找不到JDK后,按back,再按next,OK,找到了。囧。

更悲剧的是安装ADT时,install new software时总要提示打不开XXX,缺WST之类的一些库,下载时也经常出错。于是换用更大的版本,如RCP或者建模版之类,问题仍旧。后来在虚拟机上解开一个Eclipse for java developer版本,才100M的,居然安装ADT成功!可恨。是虚拟机有代理跳墙的原因还是其它?点开for java developer的features和plugin目录一看,里面居然有wst等等一大堆东西,而更大的Classic和RCP/modelling版却没有。真是岂有此理。解开一个Classic版,再将java版的features和plugins目录中东西复制入Classic版中相应目录,安装ADT,很快成功。无语。

最终安装过程:

安装Eclipse for java developer版

安装Android SDK的exe 安装版,安装完成后会自动启动下载,默认安装所有相关开发包。

在Eclipse for java中install new softwares里,增加ADT plugin的地址,安装,无任何问题,成功。

配置Eclipse的perferent,将Android节点路径指向SDK的android-sdk路径(tools和add-ons等的上一层),此时点apply,将自动识别出所安装的数个sdk和包。

此时可创建AVD,选择某版本(通常选希望软件运行的最低版本)后,创建AVD成功。

原创文章,作者:苏葳,如需转载,请注明出处:https://www.swmemo.com/276.html

发表评论

您的电子邮箱地址不会被公开。